Call Us: 1.888.448.2211

Server Software Download

After reviewing the prerequisites, 

Click here to download the latest release

 

Prerequisites

Here are the prerequisites for upgrading or installing our current server release.

  • Windows 2012 is the preferred Operating System (OS) (a virtual machine with two processor cores and 2GB of RAM will work). IIS role needs to be installed on the server with ASP.NET and Windows Authentication enabled. If this is a new server, then the itrezzo service account needs to be in the "Local Administrators" group on this system. For more information see the link to our wiki below.
  • "Microsoft .NET Framework 4.5" must be installed. It is available here
  • "If you are using Exchange Server 2007, the MAPI Client and Collaboration Data Objects 1.2.1 (MAPI/CDO), version 6.5.8244" must be installed. It is available here

Click here to access the installation notes on our wiki

Click here to access the release notes on our wiki


If you need to Uninstall software, click here

 

For the itrezzo software license agreement, click here